UniFi - métodos de camada 3 para adoção de UAP e gerenciamento

Visão geral


Os leitores aprenderão os diferentes métodos de camada-3 para implantar UAPs.

Em muitas implantações onde não é possível/desejado ter funcionando com a premissa de controlador, você pode executar o controlador na nuvem ou seu NOC. Dizer que temos um projeto em grande escala com muitos UAPs, nós poderíamos:

  • Na Amazônia, criar uma instância do controlador virtual no EC2 .
  • Configurar/estágio alguns APs em nosso laboratório e personalizar os portais de comentários.
  • Quando estamos no local do cliente, abra um navegador para o controlador baseado em nuvem.
  • Configurar o servidor DHCP, servidor DNS, ou simplesmente usar o utilitário de detecção de UniFi tornar todos os APs locais informar o controlador.
  • Em curso gestão e monitoramento pode ser feito em qualquer lugar e a Amazon poderia nos fornecer com as configurações de firewall grande.

Sumário

  1. Configuração inicial
  2. Utilitário de descoberta
  3. DNS
  4. Opção de DHCP 43
  5. SSH

 

Configuração inicial


Por favor, certifique-se que você está familiarizado com a forma como UniFi obras (por exemplo, onde AP e controlador está no mesmo L2) antes de você tentar gestão L3. Gestão de L3 adiciona muitas partes móveis na mistura (ou seja, complexidade adicional).

UniFi-AP tem um padrão de informar a URL http://unifi:8080/informar . Assim, o propósito de usar DHCP opção 43 ou DNS é permitir que o AP para saber o IP do controlador.

Utilitário de descoberta


Não muitos ambientes podem ter um servidor DHCP que é configurável, ainda menos provável com um servidor DNS. É onde UniFi Discovery Utility entra. Escuta para os pacotes de multicast/difusão de UniFi APs e permitem que você dizer o AP para informar qualquer URL que você gostaria. (apenas APs à revelia do Estado ou não em contato com qualquer controlador serão exibidos)

Descoberta de UniFi utilitário é instalada juntamente com seu controlador UniFi.

  • No Windows, é no Menu Iniciar-> Ubiquiti UniFi-> UniFi-descubra
  • No Mac, /Applications/UniFi-Discover.app (ou uso Spotlight para encontrá-lo)
  • Execute "java-jar <unifi_base>/lib/ace.jar descobrir"

Para realizar a adoção de L3 com o utilitário de descoberta:

  1. Espere até que apareça o AP
  2. Se o AP não está no estado padrão. clique em "reset", especificar o SSH username e senha e clique em "Apply"
  3. Clique em "gerenciar", modificar a URL inform e deixar o nome e senha do SSH como ubnt/ubnt e clique em "Apply"
  4. Abra um navegador para seu controlador remoto de UniFi e você deve vê-lo sendo "Aprovação pendente"
  5. Clique em "aprovar". Você vai vê-lo ir para o estado "Adotando", ignorá-lo, como ele vai eventualmente se tornar "Adoção falha" ou "Desconectado"
  6. executar [3] novo (sem necessidade de esperar por [5] para terminar)
  7. AP é agora gerida pelo controlador

Uma vez adoptada, o controlador irá atualizar automaticamente estas unidades.

DNS


  • Você precisará configurar o servidor DNS para resolver o 'unifi' para o endereço IP do seu controlador. Certifique-se de que AP pode resolver o nome de domínio do controlador . Por exemplo, se você estiver definindo http://XYZ:8080/informar , então ping da AP para determinar se a XYZ é resolvível/acessível.
  • Ou, usando FQDN para o controlador de informar a URL, http://FQDN:8080/informar
  • Solução de problemas - AP (com IP estático) falha para se conectar ao controlador de L3
    • Quando configurado um AP do DHCP para estático no controlador de interface do usuário, certifique-se de você ter colocado o IP de DNS . Se não, então o AP não pode contatar o DNS para resolver o nome de domínio do controlador.
    • se a AP foi redefinido (pressionando o botão de reset), certifique-se de que você tenha informado AP duas vezes (usando o utilitário discovery) sobre a localização do controlador (isto será melhorado na versão 2.3.0 próximo)

Opção de DHCP 43


Se usando roteadores de EdgeMax do Ubiquiti, opção DHCP 43 pode ser feita digitando apenas o endereço IP do controlador de UniFi no campo "unifi" no servidor de dhcp.

Para usar DHCP opção 43, que você precisará configurar o servidor DHCP. Por exemplo:

Servidor de Linux ISC DHCP: dhcpd. conf

# ...
option space ubnt;
option ubnt.unifi-address code 1 = ip-address;

class "ubnt" {
        match if substring (option vendor-class-identifier, 0, 4) = "ubnt";
        option vendor-class-identifier "ubnt";
        vendor-option-space ubnt;
}

subnet 10.10.10.0 netmask 255.255.255.0 {
        range 10.10.10.100 10.10.10.160;
        option ubnt.unifi-address 201.10.7.31;  ### UniFi Controller IP ###
        option routers 10.10.10.2;
        option broadcast-address 10.10.10.255;
        option domain-name-servers 168.95.1.1, 8.8.8.8;
        # ...
}

Cisco CLI

# assuming your UniFi is at 192.168.3.10
ip dhcp pool <pool name>
network <ip network> <netmask>
default-router <default-router IP address>
dns-server <dns server IP address>
option 43 hex 0104C0A8030A # 192.168.3.10 -> CO A8 03 0A

# Why 0104C0A8030A ?
#
# 01: suboption
# 04: length of the payload (must be 4)
# C0A8030A: 192.168.3.10

Mikrotik CLI

/ip dhcp-server option add code=43 name=unifi value=0x0104C0A8030A
/ip dhcp-server network set 0 dhcp-option=unifi

# Why 0104C0A8030A ?
#
# 01: suboption
# 04: length of the payload (must be 4)
# C0A8030A: 192.168.3.10

A Cisco tem uma boa write-up para a configuração de DHCP opção 43 .

Para usar o IP do controlador de
  • Você também pode usar o IP do controlador na inform URL em vez do nome de domínio.

SSH


Se você pode SSH para o AP, é possível fazer L3-adoção via comando CLI:

# 1. make sure the AP is running the same firmware as the controller. If it is not, see this guide: Upgrading UniFi firmware via SSH.
# 2. make sure the AP is in factory default state
#    if it's not, do
#    syswrapper.sh restore-default
# 3. ssh into the device and type
mca-cli
# the CLI interface:
set-inform http://ip-of-controller:8080/inform
Powered by Zendesk