PEA - métodos de capa 3 para la adopción de la UAP y gestión

Resumen


Los lectores aprenderán los diferentes métodos de layer 3 para el despliegue de UAPs.

En muchas implementaciones donde no es posible/desea tener controlador funcionando en el predio, se puede ejecutar el controlador en la nube o el NOC. Decir que tenemos un proyecto a gran escala con muchos UAPs, podríamos:

  • En Amazon, crear una instancia de controlador virtual de EC2 .
  • Configurar escena unos APs en nuestro laboratorio y personalizar los portales de la huésped.
  • Cuando estamos en el sitio del cliente, abrir un navegador para el controlador basado en la nube.
  • Configurar servidor DHCP, servidor DNS, o simplemente utilizar la utilidad de descubrimiento de PEA hacer todo APs locales informar nuevamente al controlador.
  • Gestión y monitoreo en curso puede realizarse en cualquier lugar y Amazon nos proporcionaría con configuraciones de gran cortafuegos.

Contenido

  1. Configuración inicial
  2. Utilidad de descubrimiento
  3. DNS
  4. Opción DHCP 43
  5. SSH

 

Configuración inicial


Por favor, asegúrese de que está familiarizado con cómo UniFi funciona (e.g. donde AP y el regulador está en el mismo L2) antes de intentar L3 gestión. L3 gestión añade muchas partes móviles en la mezcla (es decir, de mayor complejidad).

UniFi AP tiene un defecto informar URL http://unifi:8080/informar a . Así, el propósito de usar DHCP opción 43 o DNS es permitir la AP conocer la IP del controlador.

Utilidad de descubrimiento


Ambientes no pueden tener un servidor DHCP que es configurable, incluso menos probable con un servidor DNS. Es donde UniFi utilidad de descubrimiento. Escucha los paquetes de multidifusión/difusión de UniFi APs y permiten a la AP para informar a cualquier URL que desea. (sólo APs en estado o no en contacto con cualquier controlador se mostrará)

Utilidad de descubrimiento de la PEA se instala junto con su controlador de PEA.

  • En Windows, está en menú Inicio-> Ubiquiti UniFi-> UniFi-descubrir
  • En Mac, /Applications/UniFi-Discover.app (o utilice Spotlight se encuentra)
  • Ejecutar "java-jar <unifi_base>/lib/ace.jar descubrir"

Para realizar la adopción de L3 con la utilidad de descubrimiento:

  1. Espere hasta que la AP
  2. Si el AP no está en el estado por defecto. Haga clic en "reset", especifique el SSH username/contraseña y haga clic en "Aplicar"
  3. Haga clic en "administrar", modificar la URL de informar y dejar el SSH username/contraseña como ubnt/ubnt y haga clic en "Aplicar"
  4. Abra un navegador a su mando UniFi y verá que es "Pendiente de aprobación"
  5. Haga clic en "aprobar". Verás que al estado "Adoptar", ignorar como va finalmente a convertirse en "Adopción fallida" o "Desconectado"
  6. realizar [3] nuevo (sin necesidad de esperar [5] hasta el final)
  7. AP es ahora manejado por el controlador

Una vez aprobado, el controlador actualizará estas unidades automáticamente.

DNS


  • Usted necesitará configurar su servidor DNS para resolver 'PEA' dirección IP del controlador. Asegúrese de que AP puede resolver el nombre de dominio del controlador . Por ejemplo, si está configurando http://XYZ:8080/informar a , entonces ping de AP para determinar si XYZ es resoluble/accesible.
  • O, usando FQDN para el controlador informar URL, http://FQDN:8080/informar a
  • Solución de problemas - AP (con IP estática) es incapaz de conectar con el controlador de L3
    • Cuando se configura un AP de DHCP estáticos en el controlador de interfaz de usuario, asegúrese de que le has puesto el IP del DNS . Si no es así, entonces el AP no puede contactar con DNS para resolver el nombre del controlador de dominio.
    • Si el AP se ha reajustado (pulsando el botón reset), asegúrese de que usted informó a AP dos veces (usando la utilidad de descubrimiento) sobre la ubicación del controlador (esto mejorará en la próxima versión 2.3.0)

Opción DHCP 43


Si utiliza routers EdgeMax de Ubiquiti, opción DHCP 43 puede hacerse ingresando a la dirección IP del controlador UniFi en el campo de "PEA" en el servidor de dhcp.

Para utilizar DHCP opción 43 necesitará configurar el servidor DHCP. Por ejemplo:

Servidor ISC DHCP Linux: dhcpd.conf

# ...
option space ubnt;
option ubnt.unifi-address code 1 = ip-address;

class "ubnt" {
        match if substring (option vendor-class-identifier, 0, 4) = "ubnt";
        option vendor-class-identifier "ubnt";
        vendor-option-space ubnt;
}

subnet 10.10.10.0 netmask 255.255.255.0 {
        range 10.10.10.100 10.10.10.160;
        option ubnt.unifi-address 201.10.7.31;  ### UniFi Controller IP ###
        option routers 10.10.10.2;
        option broadcast-address 10.10.10.255;
        option domain-name-servers 168.95.1.1, 8.8.8.8;
        # ...
}

CLI de Cisco

# assuming your UniFi is at 192.168.3.10
ip dhcp pool <pool name>
network <ip network> <netmask>
default-router <default-router IP address>
dns-server <dns server IP address>
option 43 hex 0104C0A8030A # 192.168.3.10 -> CO A8 03 0A

# Why 0104C0A8030A ?
#
# 01: suboption
# 04: length of the payload (must be 4)
# C0A8030A: 192.168.3.10

CLI de Mikrotik

/ip dhcp-server option add code=43 name=unifi value=0x0104C0A8030A
/ip dhcp-server network set 0 dhcp-option=unifi

# Why 0104C0A8030A ?
#
# 01: suboption
# 04: length of the payload (must be 4)
# C0A8030A: 192.168.3.10

Cisco tiene un bueno reseña para la configuración de DHCP opción 43 .

Para usar IP del controlador de
  • También puede utilizar el IP del controlador en la URL del informe en lugar del nombre de dominio.

SSH


Si puedes SSH al AP, es posible hacer L3 adopción vía CLI orden:

# 1. make sure the AP is running the same firmware as the controller. If it is not, see this guide: Upgrading UniFi firmware via SSH.
# 2. make sure the AP is in factory default state
#    if it's not, do
#    syswrapper.sh restore-default
# 3. ssh into the device and type
mca-cli
# the CLI interface:
set-inform http://ip-of-controller:8080/inform