UniFi - Supported Java/JRE Version

NOTE: Currently, Java version 9 is incompatible with the controller. We are now working towards this compatibility.

UniFi 5.6.30 Stable Release: As of UniFi Controller version 5.6.x we dropped support for Java 6. The minimum supported version of Java is 7, but we highly recommend version 8. At this time Java 9 is not supported.

UniFi 5.7.X Beta Releases: As of 5.7.x, we only support Java 8, which is the current LTS (Long-Term Support) release as designated by Oracle, this version is recommended for all controller deployments. For access to the Beta blog see this article: How To Sign Up for Early Access.