UniFi - Recommended Minimum System Requirements

 Overview


These are the minimum system requirements for the UniFi Controller to run optimally.


Operating System:

  • Ubuntu Desktop / Server 14.04 or later (LTS Releases, 16.04 recommended)
  • Debian 7 “Wheezy” or later (LTS Releases, 8 recommended)
  • macOS Mavericks 10.9 or later (10.12 recommended)
  • Windows 7 or later (10 recommended)
  • Windows Server 2008 or later (2016 recommended)

CPU: x86-64 Processor (Intel / AMD x64 Processors)*

RAM: 1GB for Headless Servers; 2GB for GUI*

Network: 100Mbps Wired Ethernet*

HDD: Minimum 10GB free (20GB or more preferred)*

Java: Java Runtime Environment (JRE) 8

Web Browser: Google Chrome

MongoDB: version 2.6.10. (Mongo is offered bundled, so most users will not need to acquire separately. Some distros might use a slightly older version, but v2.6.10 is the one typicallybundled in the Windows/Mac packages, and hence what we will recommend here).

 info_i_25x25.png *Actual Storage, CPU, RAM and Network speed requirements will depend on many factors including the number of UniFi devices managed by the controller, number of clients, features enabled, and data retention settings. For database repair you require free space equal to the current database size, plus 2GB.